creatures caves welcome, guest
downloads   gallery   dev   community   creatchi   forum   mycaves
bookmarks | search | post new topic
Help Forum
C3 Genetics Kit Woes   

United States  


This has probably been asked time and time again, and I did try to find an answer on the forums before making this post, but nobody seems to have quite the same issue I have. I'm having trouble installing the C3 Genetics Kit on Windows 10. However, instead of having trouble with the installation process itself, I can't seem to even execute the installer at all.

For reference, I'm using the version available on, the one that comes with the activation info.

When I attempt to run the installer, I get a notification that "This app cannot run on your PC". I've tried various compatibility modes to no avail. When I get to the "test your program" step of troubleshooting compatibility, nothing happens at all (not even the aforementioned error), and if I save the settings and try to run the setup I get the same result as if I hadn't done anything at all.

I've tried compatibility modes, running as admin, running as admin in compatibility modes, no dice. When I try to run it from command prompt, in addition to the error, I get "Access is denied", assumedly due to the error.

Is my computer too new for this program? Is a VM my only option? Or is there some sort of "magic setting" I can set or file I can download to make my computer recognize that this is, in fact, a Windows program?

Back in the day, I could get it to work on my roommate's laptop, but I am no longer living with them and this is the only computer I have. I believe they were running Windows 7, but my memory often fails me these days.

Flib dis



 visit Malkin's website: Malkin's page at CWiki

Have you tried the Remastered Patch?

My TCR Norns



Malkin wrote:
Have you tried the Remastered Patch?

Installed, same error. It seems to be some sort of incompatibility with my operating system.

It's not an error I'm receiving from within the program, rather my OS is complaining about the executable and not executing it.

Flib dis



I'm having trouble with it too. But it's not throwing up any errors; instead the installation bar fills up near-instantly and then nothing happens. The installer stays up indefinitely, and cancelling/closing it tells me that the installation has not finished. I have tried the remastered patch, compatibility modes, and running as admin, but it hasn't made a difference. Thankfully though I have found a good alternative in the meantime.



That's odd. I'm also on Windows 10, but I managed to get the kit working. I am using this copy of the Genetics Kit. The Genetics Kit requires Docking Station installed to function. I actually have two copies of Docking Station installed for some reason. Can you two tell me about your installation of Docking Station?

Are you using Windows in S mode? Or Windows 10 on ARM? The ARM processor has issues running apps meant for INTEL processors.

This could be an issue with Windows SmartScreen. Go to "App & browser control" and look under "Check apps and files" to see what setting it's on. If it's set to block, change it to warn. Don't turn it off for security reasons.

Maybe side-loading is disabled on your computer. Go to "For developers", under "Use developer features". The setting should be on "Sideload apps".

Peppery One



My first guess would be that the permissions of the file itself are screwed up perhaps. When you right click the file and go into properties, is it even allowed to run as executable? Might be a stupid question considering you already tinkered with compatibility settings.

Lets play plants! Photosynthesis... Photosynthesis... Photosynthesis...



Update, tried cyborg's link, and managed to get the installer up.

Now I'm having THEdragon's problem. So close...

Flib dis



Is Docking Station installed in the Documents folder or is it installed in Program Files? All Creature games should only be installed in the Documents folder.

Are you using the GOG version of Docking Station? There have been reports of the GOG copy of Creature games of being um problematic.

To test if Docking Station is installed properly, download the Catalogue Tester.




I've got the GOG version, but everything is installed in My Documents and the catalogue tester said everything was good. Not being blocked by Smartscreen either. Hmmm! Peculiar.



Ok. I got two copies of Docking Station installed. One from GOG, the other from this fansite which I infer is the Docking Station version from the original Gameware website.



I got a new laptop and now I got the same problem here.
I believe it's an issue with WinZip Self-Extractor.

Here is the error message:
Setup Initialization Error
Setup is unable to find installation languages in C:/Users/username/AppData/Local/Temp/WZSE2.TMP/SETUP.LID file.
Error 105

I used Z-zip to extract the files for me. When the prompt come to enter a password, I just entered the license key. It worked, I had the extracted files in my Downloads folder. But I found out that WinZip wasn't the problem. It was the Setup program.

I edited SETUP from the newly extracted folder. Changed EnableLangDlg=Y to EnableLangDlg=N.

This fixed the error, but a new error popped up, the Setup program refused to respond. I am going to run the Setup various compatibility modes.

I'll post again when I make more progress on fixing this.




It works! I think I accidentally left the installer running overnight while my computer was in sleep mode. Or maybe I didn't. I just woke my laptop from sleep mode and I think the splash screen popped up.

I set the Setup.exe to Windows 95 mode.



  6/2/2021  2

Thought I'd revive this thread with a few more details as to the nature of my problem. Unfortunately none of the solutions offered here so far have done much at all.

I have tried both the auto-extractor and manual extraction with task manager open to see if I could spot any issues, and it looks like the issue is with the setup program itself. Both create a "32-bit Setup Launcher (32 Bit)" process that does not do anything visible other than exist in task manager. No popups, no errors, no windows of any kind. With the auto-extractor, it is created as a subprocess (if that's the term) under the extractor, and with manual extraction it's created as a background process. Both seem to do the same thing -- absolutely nothing. Task manager says they are using zero CPU, which tells me they aren't even trying to do anything.

I tried various compatibility modes, running as administrator, even letting the process run for over a week straight after reading cyborg's most recent solution. The result is always the same -- the process simply sits there eating about 2M of memory doing utterly F.A.

I've considered setting up a virtual machine specifically for genetics work, but my laptop screen is broken (I'm using an external one) so I have no way to see what I'm doing in the BIOS to enable virtualization. (I've tried navigating the BIOS blind and several suggestions found on the web to force the display to the external monitor with no luck.)

I'm simply out of ideas. At this point, I'd accept suggestions for genkit alternatives (even user unfriendly ones) as much as suggested fixes for genkit itself.

My only remaining thought is to ask my mother permission to try it on her computer. I really would prefer to stick to my own machine, though. I'm not keen on messing around too much with someone else's stuff. I have my doubts anyways as both our laptops are around the same age and run the same OS. I consider myself fairly computer literate (I'm in the process of obtaining a computer science degree), but I'm simply out of ideas.

EDIT: No dice. Mom's computer showed the same issues as listed here. I did see some other options listed on EemFoo, so I'll try some of those and see if I can get one to work.

EDIT 2: This will probably be my last post in this thread unless I find a solution for the official genetics kit. I found and attempted to install Dennis Murczak's Genetics Lab (listed as Gene Lab v2.1 (EN).zip on EemFoo) and to my absolute delight it works like a charm. Unless an actual fix is found, I would highly recommend this as a "solution" to anyone suffering the same issues as me.

Flib dis

hack shack
script reservations
dev resources
active projects
dev forum
log in
lost pw
0 online
creatures caves is your #1 resource for the creatures artificial life game series: creatures, creatures 2, creatures 3, docking station, and the upcoming creatures family.

contact    help    privacy policy    terms & conditions    rules    donate    wiki